Ruby hosting service specifications and features

31 de octubre, 2015 @ 23:59 — 0 comentarios

Our hosting, reseller and Cloud Premium services offer a convenient, easy to use and cheap solution for hosting almost any kind of Ruby application.

Main features

  • We use Apache and Passenger
  • You can choose between 5 different Ruby Stacks
  • There are no preinstalled Gems, but you can install any gme you may need.
  • Any gem you install will be accessible to all apps hosted in the same hosting account
  • Support for a Rails versions from 2.3 to 4.2

5 different Ruby stacks to choose from

Since August 15, 2015 we offer 5 different Ruby stacks: Ruby Ura, Ruby Sua, Ruby Lur, Ruby Hai and Ruby Kon.

All our hosting, reseller and Cloud Premium services allow to use any of the 5 stacks, but it's only possible to use a single stack per hosting account at the same time. In other words: once you have created an app, you can create another app using a different stack in the same hosting account.

The 5 stacks differ in the Ruby and RubyGems versions:

  • Ruby Kon: Ruby 2.2 with Rubygems 2.4.x
  • Ruby Hay: Ruby 2.1 with Rubygems 2.2.x
  • Ruby Lur: Ruby 1.9 with Rubygems 1.8.x
  • Ruby Sua: Ruby 1.8.7 with Rubygems 1.5.x
  • Ruby Ura: Ruby 1.8.7 with Rubygems 1.3.5

Specific specs of each stack

Ruby Kon

  • Ruby 2.2
  • Rubygems version is 2.4.x
  • Compatible with Rails 3, 4 and 5

Ruby Hai

  • Ruby 2.1
  • Rubygems version is 2.2.x
  • Compatible with Rails 3 and 4

Ruby Lur

  • Ruby 1.9.3
  • Rubygems version is 1.8.x
  • Compatible with Rails 2 and 3

Ruby Sua

  • Ruby 1.8.7
  • Rubygems version is 1.5.x
  • Compatible with Rails 2 and 3, but only up to 3.2

Etiquetas: